• A friendly and periodic reminder of the rules we use for fostering high SNR and quality conversation and interaction at Stormtrack: Forum rules

    P.S. - Nothing specific happened to prompt this message! No one is in trouble, there are no flame wars in effect, nor any inappropriate conversation ongoing. This is being posted sitewide as a casual refresher.

Warnings On Network Attached (NAS) Storage

Good day all,

Edit: Many of these NAS servers claim "Gigabit" performance but are limited by the "iSCSI" actuality of 100 (not 1000) over a network! For speed, have the drive(s) IN the machine you are working on (connected by SATA-2 or such)!

215392-iomega-storcenter-ix4-200d-nas-server-front.jpg


Above: Looks familiar? The Iomega IX-200 seems like an awesome solution to storing HD video / archiving? That it IS ... What is is NOT - However - Is "fast"!

I picked up one of these things at Tiger Direct for roughly $850. With RAID 1,5,10, JBOD (bunch of drive) options and a total of 8 TB of storage, I figured I can safely archive all 3.5 TB of digitized photos or slides, video, HD video, and audio ranging from chasing to family / special events, as well as stream over my LAN through a set-top WD Live box I also have. The "backup" part this is perfect for (if you are really patient), but when trying to play / access the videos or data, that's another story.

The unit "claims" it has a Gigabit LAN (2 10/100/1000 ports) capability. Plugging it in was a breeze, and configuration was a snap. With four 2-TB SATA-2 drives (8 TB total) ... I configured it to RAID-5 (about 6 TB). This required a low-level format, which takes about an hour per 250 GB, so I let that do it's thing overnight. The next day, I was ready to back-up and go.

I tried copying a 5 GB HD video file from my laptop to my main PC, and since it was the new Gigabit LAN, this took roughly 50 seconds at about 125 MB/S. However, I tried to copy to the Iomega drive, and it CRAWLED at 12.5 MB/S, decaying to 7.5 MB/S, basically 100 LAN speeds, and took about 8 minutes.

I questioned the RAID-5, then tried the same thing with RAID-10 (two 4-TB mirrors of two drives spanned together) ... Still, it crawled, made no difference. Same results from NO RAID, so that ruled out that. Double-checked the LAN speed and it was honking with everything else at full Gigabit (100+ MB/S).

Note: Net speeds ... 10 ~ 1 MB/S, 100 ~ 12 MB/S, 1000 (Gigabit) ~ 120 MB/S (there are 8-bits plus parity to a Byte).

I was able to yank out one of the SATA drives from the Iomega unit, and plug it into a spare slot on my PC motherboard. The same 5 GB test file flew along at at least 150 MB/S, copying in roughly 30 seconds ... Same as my other internal drives did. The conclusion was the crappy interface for the LAN on the Iomega unit (bringing the unit to my job, on their system, also confirmed this).

With my copy of 3.5 TB of data taking about a hapof a week to copy to the Iomega RAID, I was very discouraged. Even worse, the 5 GB file would not even play. I'd click on it, and it just sit there, after 20 seconds, it jumped, then media player crashed, really hard - so hard, I had to reboot the PC into safe mode! Playing a smaller MPG file, a bit faster, but also froze. Another attempt even blue-screened my machine! All these video files played perfectly from my USB 2.0 based 2 TB drive.

I deleted (re-formatted) and returned the Iomega unit to Tiger Direct via RMA, eating the shipping. As an experiment, I bought a "My Book" DUO from Western Digital the same day at Besy Buy. This is basically RAID-1 (mirror) of two 2 TB drives. It also "claims" to have a single Gigabit interface. I tried this one, and basically the SAME results: Got no more than 11 MB/S transfer rates. At least this one was much easier to return ;-(

The final decision was to simply buy two 3 TB SATA drives (about $219 each) and place them as a mirror (RAID-1) in my PC, and removed the older 1 TB drive and put it into a spare USB 2.0 enclosure. It took only a few hours to copy my data to the internal 3-TB mirror (leaving out some non-essentials I backed up on the spare USB one anyway. The speed is awesome, because its using the RAID-1 off the PC's motherboard. Over the network, the copy rate is at least 125 MB/S.

The point of this WHOLE thing ... Those NAS devices are really great for storage, backups, or even cloud computing. But don't even try to use them for accessing / playing video over a network (let alone editing video). They made a super deal simply because they put garbage network adapters into them.

A little more research on RAID ... If you go online to Tiger Direct (or any other site / store), a "good" RAID controller you place in your computer via PCIe / PCI can set you back at LEAST $500. I am sure the Iomega / WD folks put ones that costed 1/20th of that!
 
Last edited by a moderator:
Couple things..

Believe it or not, the problem you had probably had little to do with the NAS devices or the hardware built into them (especially if you had the same issue with two different units), it has to do with your computer's network drivers as well as the quality of your network hardware. But there is absolutely no way that you achieved 125MB/s transfer between your two computers oiver 1000BASE-T. That is the theoretical maximum for Gigabit. In real life, once you account for cabling losses, switching losses, hard drive/controller bottlenecks and busline inefficiency, one can only expect to achieve 70-80% of that (84-96MB/s) as a maximum. Then there is the protocol overhead which knocks another 5% or so off. So absolute best case scenario you got 90MB/s. In real life, more like 50-60.

The main bottlenecks are the Windows network drivers and the computer bus (A PCI based integrated ethernet card maxes out at 133MB/s if nothing else is sharing the bus lines). Always make sure you have the MANUFACTURER'S latest drivers, not just what Windows installed automatically. Also ensure that your network is cabled properly.. Cat5e cable, jacks, and patch cords are the BARE MINIMUM for Gigabit. Ideally you want Cat6 to give you some extra headroom for cable losses. And they all must be terminated to spec - maintaining the twist, using a proper punch tool (not jamming the wires into the IDC with a screwdriver or the 'keeper cover'), and you must maintain at least 12" separation from any live electrical wires.

Also, all switches and routers are not equal. If you have a cheap, no-name switch or router in your network, it will not be able to handle Gigabit traffic efficiently. Even a good router's capability can benefit immensely from a custom firmware.

The standalone NAS units do 'software' RAID. They don't use a RAID controller. The reason for a (expensive) RAID controller in a computer is because the parity calculations for redundancy modes (4,5,6) are very CPU intensive, and to do software RAID on a less powerful CPU drags the whole computer down (except non-parity modes 0 and 1). A RAID board is basically a computer in itself (many even use standard SO-DIMM laptop RAM modules and many have battery backup units to protect the write cache from power failure data loss), which is why it is so expensive - it does all the parity work so it takes the load off the main CPU. In a NAS or MyBook, the CPU isn't doing much else, so it doesn't matter if it is fully utilized for software RAID - in fact that's exactly what it's designed for.. There is no need for any additional 'dedicated' RAID hardware.

That said, while write performance (copying files TO the NAS) may not be up to snuff because writing is at the mercy of the XOR engine and the max sustained write speed of the hard drives, read performance does not suffer the same problems in any mode in a healthy array because there are no calculations necessary (if a drive has failed in a parity array, the missing data is recalculated on the fly, resulting in slow read speeds). So I'm not sure what went on with your accessing of the files causing freezing and BSOD, but even full HD video doesn't require anywhere near Gigabit. In fact it doesn't even require anywhere near 100Mbps. The compressed video you tried to stream is more along the lines of 8-10Mbps (the total size of the file means nothing in regards to streaming, just the video bitrate).

The write speeds I hear you. I hit the same wall with loading up my home built server over a Gigabit network. I was only transferring at 8-10MBps. After trying to find fault in everything else, simply updating the drivers fixed the problem. Now I have a bottleneck at the RAID card, because it is older (I built the server from parts I had laying around), so the first gig or so will fly at 50MBps, but once the RAID buffer fills up, the network speed slows way down - not because the hard drives can't write fast enough, but because the XOR engine can't do the calculations fast enough. If I was doing mode 0 or 1, this wouldn't be an issue (the hard drive speed becomes the ceiling here), but I am running in mode 5.

But as far as streaming, I've never had ANY problems even with 4 clients (I use WD Live's, Apple TV, and XBMC) running at once. I would NEVER do editing on a remotely mounted drive/share though. That's just BEGGING for trouble. You always copy material to the local machine to work on it.
 
Last edited by a moderator:
Good day all,

Thanks a bunch Matt for the info ... I never even wondered about the windows drivers.

I still am wondering why the NAS performance was so slow, but everything else (Internet, copying from one PC to another, and such) was fast as you would expect over 1000BASE-T. A file copy of about 100 GB started at 125 MB/S (probably because of caching) and decayed to about 70-80 a few seconds later and remained in that ball-park to end. The NAS did anywhere from 8 to 12.5 MB/S ... Remaining towards 8 MB/S towards the end of the copy. More like "100BASE-T" speeds, not 1000.

Just FYI ... I did make sure the driver / tools for the NAS were up-to-date, as well as the latest firmware.

My solution was simply doing RAID-1 (two 3 TB drives mirrored) inside my main PC with a separate drive (750 GB for Win7 SP2 OS). I also have a 1.5 TB "spare" in another slot, with my Adobe CS4 "media cache" going into that one so I can clear it when I need to.

The machine flies in this configuration, despite it being 3 years old already! It's a 64 Bit 2.6 GHz quad-core Intel, 8 GB of DDR2 RAM (4x2048 MB), blue-ray burner, Adobe CS4, Windows 7 (SP 2) ... Should last me another "moore's law year"!
 
Yeah I agree, that 125 was basically a 'burst' rate calculation. Once the data flow stabilizes it is more in the ballpark of 'real world' speeds of 70-80.

Now.. you mentioned the 'tools' for the NAS being up to date... That right there may be what caused your bottleneck. Personally I never use any type of 'tools' or 'wizards' or any other junk that comes with a peripheral like that. Even the software disc that comes from an ISP gets thrown out. It's all bloated inefficient junk that causes more problems than it solves..

I'm not real familiar with the iomega or MyBook OS, but if I were to buy one, the first thing I would do is find some kind of custom firmware for it and install that. The stock firmwares that come on most devices are designed for your average consumer to be able to 'plug and play' - which sacrifices flexibility and performance in the name of simplicity.

I would also find a way to make it accessible as an SMB/CIFS share (one that shows up directly in Windows under your network), and I would 'map' it as a lettered drive. That eliminates any need for 'helper' software, and all the problems that go with it.

And Moore's law isn't as applicable as one would think when it comes to what most people need.. Yes, technology is obsoleting faster and faster, but even obsolete hardware can serve a purpose! For example, the server I built - it's an old P4 2GHz box (easily 10 years old) that I stuffed 2GB of RAM, a Gigabit card, and an old 8 channel SATA RAID card into.. It runs six 2TB drives online in RAID-5 (10TB total) plus two hot spares. It also has an 80GB system drive. It has no issues running Windows Server 2008 (it won't run the latest RC2 though, because that only comes in 64 bit). It's primary role is a file server/source for media streaming, but it also stores nightly backups from all of my computers, and it also acts as a print and fax server.

As I said the only issues I have occur when loading it up with large files (larger than 1.4GB). It'll do 1.4GB in about 20 seconds, then it slows way down when the RAID buffer is full.. So a 6 or 7GB DVD rip takes roughly 10 minutes to copy onto the array (even when ripped locally to the system drive and copied to the array - that's how I know the RAID card is bottlenecking, not the network). But it has no issue whatsoever with streaming or transferring files FROM the server.

Would I trust that server to the stresses of a corporate network? Absolutely not! But it works just fine for what I need it to do!! :D
 
This is what I'm talking about. All of my remote drives are mapped to show up directly in Windows as lettered drives without having to use any sort of 'helper' software. I'd make book that software is what dragged your speeds down and caused your computer to crash.

88487133.png
 
Back
Top