Spotter Network location not showing up on RadarScope

So every time I log in to Spotter Network on RadarScope it never shows my location. I have passed the test on the website, and when I use my GPS Puck that's connected to my laptop and run the GPS off of the SpotterNetwork app on the computer my location shows up on the radar. I was just curious if anybody knew what was going on because I don't understand why it wouldn't show up on the RadarScope app but it shows up on radar when using the Spotter Network app on the computer. Hope that makes sense.
 

Mark Blue

Staff member
Supporter
Feb 19, 2007
2,773
317
21
Colorado
Do you have RS’s settings configured to login to the SN service with your SN credentials?

Please confirm the version of RS you’re using. Is it Windows, iOS, or Android?
 

Mark Blue

Staff member
Supporter
Feb 19, 2007
2,773
317
21
Colorado
I’d recommend going through some material here https://www.radarscope.app/take-a-tour. I can’t really compete with the FAQs and user guide already written by the developers.

I think the one step most folks fail on is turning on location services by pressing the location button on the toolbar. Once enabled your red beacon should appear within 2 minutes.
 
I’d recommend going through some material here https://www.radarscope.app/take-a-tour. I can’t really compete with the FAQs and user guide already written by the developers.

I think the one step most folks fail on is turning on location services by pressing the location button on the toolbar. Once enabled your red beacon should appear within 2 minutes.
Thanks! You know what, I bet that is the reason why it won't show up!

Sent from my Pixel 2 using Stormtrack mobile app